Welcome, Guest. Please Login or Register
Home Help Search Login Register
Page Index Toggle Pages: 1
Send Topic Print
sIBL_GUI v4.0.2 - Silent deployment problem (Read 6318 times)
gboucher
Ex Member


sIBL_GUI v4.0.2 - Silent deployment problem
09/02/12 at 17:30:02
 
Hi, I'm working for a public school and I need to deploy sIBL_GUI v4.0.2 to about 200 computers on Windows 7 Ent SP1 x64. So I use these steps to do it.

1- Copy sIBL_GUI.exe to the target computer.
2- Launch sIBL_GUI.exe /s
3- Copy these folders where they must be
prefs (%UserProfile%\Documents\maya\2012-x64\prefs)
scripts (%UserProfile%\Documents\maya\2012-x64\scripts)
sIBLedit103 (%UserProfile%\Documents\maya\sIBLedit103)
4- I use a script to automatically modify the file %UserProfile%\Documents\maya\sIBLedit103\sE.ini so that the correct user name profile appears in it.
5- Copy this folder Standard_sIBL here:
(%UserProfile%\Documents\sIBL\Standard_sIBL)
6- Finally I create a shortcut in the start menu to sIBLedit.exe.

The same steps where used with version 3.5.0 and it works perfectly. Now, I discovered that with version 4.0.2 the user need to launch at least once sIBL with administrator rights before he can launch it himself with standard user rights. Is that normal? Am I missing something here?

All help will be much appreciated!
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #1 - 09/02/12 at 19:16:27
 
Hi,

Yeah it's an issue with the packaging tool I used to freeze the application, basically it's creating some folders in the installation directory instead of the %TEMP% directory, as a result if you are not admin the first time and installed sIBL_GUI in %PROGRAM_FILES% the program cannot start.
I opened an issue: https://github.com/KelSolaar/sIBL_GUI/issues/158

Maybe what you can do for now is try copying that folder with its content on all your installation as a workaround:

sIBL_GUI 4/support/

Let me know how it goes!

KS
Back to top
 
 
IP Logged
 
gboucher
Ex Member


Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #2 - 09/02/12 at 21:38:46
 
Hi Kel Solaar!, it confirm what I thought. Until it get fix I just added 3 more steps to my installation process. First, I launch as an admin sIBL_GUI.exe. Then my script waits 30 seconds. By then the user is presented with the windows popup about if he want to add some Ibl Sets. Then I just kill the sIBL_GUI.exe process. Now any user can launch sIBL_GUI without any problem.

Thanks again for the help!
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #3 - 09/03/12 at 00:14:14
 
You are welcome Smiley

I'll get that sorted hopefully in the next release Smiley

KS
Back to top
 
 
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #4 - 09/03/12 at 09:54:06
 
Hi gboucher,

Welcome here, and thanks for this massive installation. Makes us all very proud to be used in an entire school network.

However, I recommend a shared setup.
Our IT guy just did a similar deployment script, but we opted to use a centralized database so it can be managed by the lighting TD for everybody.

- mount the shared network folder as L: drive (which is our asset library)
- modify the sIBL shortcut link on each installation's desktop by adding
-d L:\SmartIBL\database -r

- save all the default sIBL sets on the same server (but a different subdirectory than the actual database file, for example L:\SmartIBL\default_collection).

My machine does not have the -r in the shortcut, which means  the database is not write protected for me and I have the glorious task of housekeeping it for everybody. Wink


PS: The administrator login trouble was also biting us, but in the 3dMAX script that launches the OLE server for the first time. Would be awesome to see a solution for that.
Back to top
 
WWW  
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #5 - 09/03/12 at 14:42:15
 
Hi Chris,

Regarding 3dsmax OLE Server registration, I'm afraid that there is no solution: the script is writing informations in the registry in sections that need Administrator rights.

KS
Back to top
 
 
IP Logged
 
Dschaga
Ex Member


Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #6 - 09/03/12 at 22:46:34
 
there is maybe a way to avoid the OLE Server:

http://www.scriptspot.com/3ds-max/tutorials/how-to-create-a-self-updating-max-sc...

dunno ..maybe it still needs admin rights. (?)
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #7 - 09/03/12 at 23:51:11
 
Oh this is just to connect to an HTTP socket with Maxscript through ActiveX, it wouldn't help here unfortunately.

KS
Back to top
 
 
IP Logged
 
Dschaga
Ex Member


Re: sIBL_GUI v4.0.2 - Silent deployment problem
Reply #8 - 12/07/12 at 09:49:17
 
have a look at this discussion ..maybe a new way to use tcpi/ip?
http://forums.cgsociety.org/showthread.php?f=98&t=1082271
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print