Welcome, Guest. Please Login or Register
Home Help Search Login Register
Page Index Toggle Pages: 1
Send Topic Print
sIBL Installation Help required!! (Read 10285 times)
dEvil
Ex Member


sIBL Installation Help required!!
07/25/12 at 08:16:33
 
GrinHello folks,   Smiley Smiley
I am having hard time trying to install sIBL for maya 2011 on win7.Though followed some articles regarding installation, i could not really get to it. so kindly guide me in installation. BTW below is my config and how i tried installing it.
My config - Win7(sp1)x32;Maya2011; I generally have programs installed on different folder(d:)
as sIBL4 was x64 i tried with sIBL 3.5.0.. installed SIBL3 on d:Programfiles. upon starting gui, i connected it to the default starter pack provided.
later comes my difficult part.as per some references, when tried coping the loader script folder link inside maya it said it was an invalid folder. is it because i installed on different folder(d:)?

So anybody kindly guide me through step by step instructions and folder setups...What are the files to be downloaded for my configuration and where...waiting your responses.
Thanks in advance

dEvil
Back to top
 
 
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: sIBL Installation Help required!!
Reply #1 - 07/25/12 at 08:38:51
 
Hmm ... so you did install the helper script for Maya, right? And you're talking about the loader script path in the sIBL GUI preferences ('p' icon)?

You don't really need to set the loader script path. What you really need is the path to the executable and then you can start sIBL GUI with the circle icon (second in the shelf).

Then, when you have chosen your favorite set in sIBL GUI, just click the Send to Software button on the Export tab. If the port number below that button is the same as in the preferences, then it will build your light rig automatically.

Attached some screenshots from Maya 2012, let me know if they look helpful to you.
Back to top
 

008-sIBL-GUI-123_proxy.png (Attachment deleted)
009-sIBL-GUI-4_proxy.png (Attachment deleted)
010-sIBL-GUI-5678_proxy.png (Attachment deleted)
WWW  
IP Logged
 
dEvil
Ex Member


Re: sIBL Installation Help required!!
Reply #2 - 07/25/12 at 10:09:04
 
hey Blochi Smiley, thanks for your early reply.Though i had connected the exe path, the loader script path was also entered to which it said invalid path. C:\Users\$Users\AppData\Roaming\HDRLabs\sIBL_GUI\io\loaderScripts.
Is it because i have installed maya and sIbl in different drive other than c:. A little bit of confusion.
I have maya 2011 32bit,and sIBL_GUI 3.5.0.
1.the helper script installed shows GUI 4 in maya shelf.
2.when the second icon is launched it it shows 3.5.0 and while it loads it says change.log is not found on this server or something like that.(I hv downloaded the change.log but dont know where to save it)
3.when in second tab(export in 3.5.0). I select maya mr standard and an IBL set. and when trying to send to maya , it says 'NoneType' object has no attribute 'text'. also it says the same thing when output loader script is clicked.
what am i doing wrong to get this error. can you pls let me know the workaround.Phew! installation is producing more bugs than the maya bugs itself. Smiley I dont know what versions needs to be installed.

Thanks again.
dEvil
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL Installation Help required!!
Reply #3 - 07/25/12 at 15:51:10
 
Hello,

Issues are coming from the fact that you are using an old deprecated sIBL_GUI version!

I removed the old Change Log file from our repository, I will actually put it back but altered with a few warnings.
Basically now if you want to keep the 3.5.x because you are in 32 Bit:

Remove everything sIBL_GUI related you have:
- Uninstall the software, make sure you delete the installation directory.
- Remove the preferences.
- Delete the maya scripts / dependencies.

Once you have cleaned everything:
- Reinstall sIBL_GUI 3.5.x
- Install this version of the Maya Helper Script: http://kelsolaar.hdrlabs.com/sIBL_GUI/Support/Softwares/Maya/Helper_Script/Relea...
- At the moment you will launch sIBL_GUI, the Online Updater will kick in, you will have the Change Log missing stuff, anyway: NEVER UPDATE YOUR TEMPLATES! The templates for sIBL_GUI 4 are not compatible with the one for sIBL_GUI 3, you should deactivate the Online Updater in the preferences.

From there you should be fine Smiley

KS
Back to top
 
 
IP Logged
 
dEvil
Ex Member


Re: sIBL Installation Help required!!
Reply #4 - 07/25/12 at 17:45:12
 
Voila!! Thanks a ton Kel.Works like charm and I couldn't wait to start."Here i come IBL sets..wait for me". Anyways thanks again for the wonderful resource Mr. Kel Soolar.

Mates!! anyone having the same issue follow Kel's steps.I proved to be a successful follower. Smiley Smiley

dEvil
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL Installation Help required!!
Reply #5 - 07/25/12 at 17:54:58
 
You are welcome!

KS
Back to top
 
 
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: sIBL Installation Help required!!
Reply #6 - 07/25/12 at 18:03:40
 
Well, and my advise would be to update Maya.

Not only because you miss out on all the new feature goodness Kel keeps adding to sIBL, but also because Maya 2013 finally looks like a usable application. Wink


Back to top
 
WWW  
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL Installation Help required!!
Reply #7 - 07/25/12 at 20:04:15
 
Yeah 64 bit all the way, if it was simple to deploy both 32 / 64 bit versions I would do it, but it's a pain :|

KS
Back to top
 
 
IP Logged
 
dEvil
Ex Member


Re: sIBL Installation Help required!!
Reply #8 - 07/26/12 at 06:24:04
 
Oh ok thanks.. i wud certainly try to move to 64bit. seems latest versions has much more ingredients for better IBL recipes.well maya mr lightsmith must be in gui4..

Kel !! though i am not aware of the pain and complexity involved in creating these,i am just of the opinion that the installation part can be made easy for us being reached as a standalone app thereby reaching more users. like- a single installation ; users get a handful of customizing options to their core needs(along with some descriptions,warnings of overwriting,etc). Again its just an opinion if there were any feedback section.

anyways thanks again
Back to top
 
 
IP Logged
 
yuval
Ex Member


Re: sIBL Installation Help required!!
Reply #9 - 07/02/14 at 14:06:04
 
Hi thare,
I'm having an issue with sIBL load:
// Warning: line 1: sIBL_GUI | No sIBL_GUI executable path defined!

What's and were's that executable path?
Need your help
Thank
yuval
Blochi wrote on 07/25/12 at 08:38:51:
Hmm ... so you did install the helper script for Maya, right? And you're talking about the loader script path in the sIBL GUI preferences ('p' icon)?

You don't really need to set the loader script path. What you really need is the path to the executable and then you can start sIBL GUI with the circle icon (second in the shelf).

Then, when you have chosen your favorite set in sIBL GUI, just click the Send to Software button on the Export tab. If the port number below that button is the same as in the preferences, then it will build your light rig automatically.

Attached some screenshots from Maya 2012, let me know if they look helpful to you.

Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print