Welcome, Guest. Please Login or Register
Home Help Search Login Register
Page Index Toggle Pages: 1
Send Topic Print
Maya MR Textures Not Loading (Read 3421 times)
Nicholas Breslow
Ex Member


Maya MR Textures Not Loading
01/18/12 at 17:15:12
 
Hi,

I just downloaded/installed the latest versions of everything (Maya 2012 SAP x64):

  • sIBL_GUI 4.0.1
    Maya Helper Script 2.0.2
    Maya Mental Ray Standard Template 2.0.4
    Updated sIBL Archive Sets


I am using the Maya Mental Ray Standard 2.0.4 template and after a quick test render I get the following info. in the script editor/output window:

Code:
LIB  0.0  error  291825: {TEXS}/<type 'file'>: registry entry {TEXS} not found
while defining texture "sIBL_background_mentalrayTexture": failed to open texture file /<type 'file'>

LIB  0.0  error  291825: {TEXS}/<type 'file'>: registry entry {TEXS} not found
while defining texture "sIBL_lighting_mentalrayTexture": failed to open texture file /<type 'file'>

LIB  0.0  error  291825: {TEXS}/<type 'file'>: registry entry {TEXS} not found
while defining texture "sIBL_reflection_mentalrayTexture": failed to open texture file /<type 'file'> 



I graphed the sIBL setup int he hypershade and it looks like the background, lighting and reflection textures files are not being setup properly.  Specicifically, if I open the sIBL_reflection_mentalrayTexture node and look in the Image Name slot it says: <type 'file'>.  I would expect it to have a path setup instead, no?

Also, executing 'Send to Software' appears to work initially - I get the message: LoaderScript | 'sIBL_Maya_Import.py' output done!.  Then I get an error: LoaderScript | Exception raised while sending Loader Script!  If I click 'Show Details...' this is the message:

Code:
File "C:/Program Files (x86)/HDRLabs/sIBL_GUI 4/sibl_gui/components/addons/loaderScript\loaderScript.py", line 660, in __Send_To_Software_pushButton__clicked
   self.sendLoaderScriptToSoftware_ui()
  File "C:/Program Files (x86)/HDRLabs/sIBL_GUI 4/sibl_gui/components/addons/loaderScript\loaderScript.py", line 784, in sendLoaderScriptToSoftware_ui
   raise Exception("{0} | Exception raised while sending Loader Script!".format(self.__class__.__name__))
Exception: LoaderScript | Exception raised while sending Loader Script! 



The only way I have been able to get it work is to execute the loader script from the sIBL Maya Shelf.  This happens whether I use MR Standard/Lightsmith or VRay/Dome/Lightsmith/Standard. 

BTW - the other Templates seem to work fine, the MR Lightsmith and Vray textures link up fine and render - only the MR Standard seems to not link.

Any help would be appreciated - thanks a lot,

-Nick Breslow




Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: Maya MR Textures Not Loading
Reply #1 - 01/18/12 at 18:39:22
 
Hi Nicholas,

Many thanks Smiley

I did a mistake while refactoring some bits of code on Maya Templates. I thought I wouldn't need to test on ALL templates if what I did was working since it was working on the test case Template. Proven to be wrong, I broke Mental Ray one. It should be fixed in the 2.0.5 Smiley

Notice that the fact it works from the shelf means you probably had sIBL_GUI 3.X.X installed and you are using executing a deprecated Helper Script that is executing the loader scripts from ../HDRLabs/sIBL_GUI/loaderScripts/ instead of ../HDRLabs/sIBL_GUI/4.0/loaderScripts/, so you are probably not executing the loader script you jut output from sIBL_GUI 4.X.X but an older one from sIBL_GUI 3.X.X

Cheers,

Thomas
Back to top
 
 
IP Logged
 
Nicholas Breslow
Ex Member


Re: Maya MR Textures Not Loading
Reply #2 - 01/18/12 at 20:40:45
 
Hi Thomas,

Works perfectly now - thanks for the quick fix.

One other thing - Then the template updated attempts to update the Maya_Arnold_Standard script it returns an error that it can't extract the archive: RemoteUpdater | Failed extracting 'Maya_Arnold_Standard.zip', proceeding to next file!

PS - I love sIBL, you guys do great work.  Thanks!

-Nick Breslow
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: Maya MR Textures Not Loading
Reply #3 - 01/18/12 at 22:09:57
 
Oh! I uploaded the file in the wrong folder :| It should be fixed by now Smiley

Thanks!

KS
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print