Welcome, Guest. Please Login or Register
Home Help Search Login Register
Page Index Toggle Pages: 1
Send Topic Print
Cannot get it work on SI (Read 2454 times)
plutarco
Ex Member


Cannot get it work on SI
01/07/12 at 07:36:50
 
Hi there,

I'd really like to try sIBL but I couldn't figure out how to properly install it for Softimage. I'm using SI 2012 Sp1 64-bit on Windows 7 x64.

Here's what I've done so far:
- installed sIBL_GUI_For_XSI addon
- installed sIBL_GUI_XSI_Server addon
- downloaded the gacutil

The sIBL_GUI_For_XSI installation went fine.
The sIBL_GUI_XSI_Server didn't succeeded, here's the error message I get:

Quote:
XSI failed to load a .NET plug-in. This error happens because the plug-in may have been compiled with a different version of XSI. Recompile the plug-in with the current version of XSI to fix the problem...


I've downloaded the server addon from this page:
kelsolaar.hdrlabs.com/?dir=./sIBL_GUI/Support/Softwares/XSI/sIBL_GUI_XSI_Server/
Stable

under the folder 2012  > x64  > 10.5.98.0  >

Said that, I guess I should do something also with the gacutil but I have no idea what.

Hope someone can points me in the right direction.
Thanks in advanced for any help.
Back to top
 
 
IP Logged
 
plutarco
Ex Member


Re: Cannot get it work on SI
Reply #1 - 01/07/12 at 10:21:38
 
I noticed only now that there's a thread already sIBL_GUI For XSI. Sorry for the confusion, I probably should have posted in that trhead.
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: Cannot get it work on SI
Reply #2 - 01/08/12 at 21:07:51
 
Hi,

It's explained in the FAQ: http://www.hdrlabs.com/cgi-bin/forum/YaBB.pl?num=1271612492

Quote:
How do I register the sIBL_GUI_XSI_Server.dll file into Windows Global Assembly Cache ?
Back to top
 
 
IP Logged
 
plutarco
Ex Member


Re: Cannot get it work on SI
Reply #3 - 01/09/12 at 05:55:45
 
Thanks Kel Solaar,

I've followed the steps in the FAQ but still is not working.
Basically I've used the Gacutils and after that I noticed there were two new folders:

Code:
C:\Windows\assembly\GAC_64\Softimage.XSIUtil\10.1.61.0__a90401fcf6bc5571\Softimage.XSIUtil.dll 



and
Code:
C:\Windows\assembly\GAC_MSIL\sIBL_GUI_XSI_Server\10.5.98.0__6255860145385afa\sIBL_GUI_XSI_Server.dll 



I'm using the following server version:
2012  >
x64  >
10.5.98.0  >

So, when I open SI I still see the error message in the status bar.
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: Cannot get it work on SI
Reply #4 - 01/09/12 at 08:02:22
 
Hi,

As an alternate way to register the dll, did you tried a simple drag'n'drop into the assembly cache folder? If you are admin it should register properly this way.

KS
Back to top
 
 
IP Logged
 
plutarco
Ex Member


Re: Cannot get it work on SI
Reply #5 - 01/09/12 at 08:17:50
 
I tried that way too, even though I wasn't sure exactly where to copy it as there are several folders. In the FAQ I read it's just about copying it into Windows\Assembly so I did but still no luck.
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: Cannot get it work on SI
Reply #6 - 01/09/12 at 09:41:45
 
Can you confirm that you are using the Addon matching you Softimage version? ( Help -> About Softimage ). The 10.5.98.0 version is not for Softimage 2012 SP1 but for Softimage 2012 SAP.

KS
Back to top
 
 
IP Logged
 
plutarco
Ex Member


Re: Cannot get it work on SI
Reply #7 - 01/10/12 at 05:59:10
 
Thanks Kel,

I've tried the other versions and now it's working. Sorry, don't know if somewhere was already specified which server zip file was needed for the proper SI version, if so I didn't find it.
But now everything is working fine, thank you very much! Sorry for bugging with newbish questions.
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: Cannot get it work on SI
Reply #8 - 01/10/12 at 07:22:32
 
Hi,

No worries, explanations are a bit scattered, definitely easy to get lost. I know I need to do proper installations guide since years now, but never found the time to do them unfortunately.

KS
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print