Welcome, Guest. Please Login or Register
Home Help Search Login Register
Pages: 1 ... 11 12 13 14 15 ... 21
Send Topic Print
sIBL_GUI For XSI (Read 80751 times)
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #180 - 04/27/10 at 00:19:50
 
Hi,

There is something that makes XSI crash in the Addon ( I can load the Workgroup one time in fact, after that  XSI keeps crashing on startup ). I didn't had time to check what the issue is, anyway in the next releases sIBL_GUI will not be included anymore directly into the Addon, the fact sIBL_GUI is a program on his own, with it's dlls and dependencies is not a thing XSI really like when he walks into the Addon directory ( There are errors with the dlls that he tries to load etc ). It was working up to now.
When sIBL_GUI 3 will reach the final release, a new addon will make the setup easier and cleaner.

Anyway here is an emergency release of sIBL_GUI 2.1.1 For XSI  :

sIBL_GUI_For_XSI.rar

- I updated the Template so it can load properly and accordingly with XSI 2011 Api changes.
- You will need to edit this line in the sIBL_GUI_For_XSI.js Plugin file of the addon :

Code:
APPLICATION_PATH = "Y:\\sIBL_GUI_For_XSI\\sIBL_GUI_Windows"
 



and put the path to the sIBL_GUI installation directory ( Don't forget the double backslashes ).

After that you should have sIBL_GUI working as usual ( I hope ).

If you have a Standalone of sIBL_GUI, here is the Template alone :
Softimage_MR.sIBLT

Sorry for the inconvenience !

KS
Back to top
« Last Edit: 04/27/10 at 08:23:47 by Kel Solaar »  
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #181 - 04/27/10 at 21:59:02
 
Hi,

I fixed some issues with the Emergency Addon :
- Paths with whitespaces werent working.
- Stripped a definition making some parts of the code failing.

The addon is available at the same place :
sIBL_GUI_For_XSI.rar

I'm also working at the next Addon, I should have something working really soon.

KS
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #182 - 05/28/10 at 23:12:32
 
Hi,

I have updated the first post to reflect the changes that happened with sIBL_GUI 3.

I also recompiled the sIBL_GUI_XSI_Server with Softimage 2011 - x64 : http://kelsolaar.hdrlabs.com/?dir=./sIBL_GUI/Support/Softwares/XSI/sIBL_GUI_XSI_...

KS
Back to top
 
 
IP Logged
 
Richard Osborn
Ex Member


Re: sIBL_GUI For XSI
Reply #183 - 06/16/10 at 21:47:03
 
Hi,

I've just started playing with sIBL and am very, very impressed.

I installed both GUI for XSI and Server on my installation of 2010 and have been experimenting...

Just today I eventually got my serial number for 2011 from Autodesk (long story!) and tried to install the sIBL addons again. The GUI for XSI worked fine but I'm getting an error with the Server addon, saying that it is compiled with the wrong version! The addon uses 9.0.242.0 but my version of 2011 is 9.0.243.0.

Not knowing how addons work I'm surprised that you need to re-compile everytime a new (and mini) version update comes along but do you have plans to release a new version of the Server addon - I'm missing it already!

Thanking you in advance.
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #184 - 06/17/10 at 16:45:01
 
Hello Smiley

The problem is that the Server Addon is a C# DLL that needs to be compiled against each new XSI version.

KS
Back to top
 
 
IP Logged
 
Richard Osborn
Ex Member


Re: sIBL_GUI For XSI
Reply #185 - 06/17/10 at 21:53:04
 
thanks for the prompt reply. Just to add to your problems Autodesk have just released Softimage 2011 SP1 (9.1.91.0)!!!
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #186 - 06/17/10 at 22:27:23
 
I'll need to get my hands on that Smiley

Though the real solution is a built in socket / remote connection support from AD. 3dsMax and Maya do it since years now ...

KS
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #187 - 06/18/10 at 22:03:28
 
Hi,

I recompiled the sIBL_GUI_XSI_Server Addon for the Softimage 2011 9.0.243.0 build. You can get it here :

http://kelsolaar.hdrlabs.com/?dir=./sIBL_GUI/Support/Softwares/XSI/sIBL_GUI_XSI_...

The Softimage 2011 Sp1 should follow anytime soon.

KS
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #188 - 07/02/10 at 23:50:53
 
Hi,

Sorry for the delay, nobody reminded me so I forgot Cheesy

I compiled sIBL_GUI_XSI_Server Addon for Softimage 2011 SP1 ( Build 9.1.91.0 ) :

http://kelsolaar.hdrlabs.com/?dir=./sIBL_GUI/Support/Softwares/XSI/sIBL_GUI_XSI_...

Don't forget the usual gacutil registration !

Let me know if you have any issues.

KS
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #189 - 08/06/10 at 14:43:17
 
Hi,

I just updated the latest sIBL_GUI_XSI_Server version so that it features a version number. That should prevent clashes in the Windows Gac when you run XSI 2011 and 2010 for example. I'll not back compile the older releases though.

In the same subject, I think it's now possible to get rid of the gacutil.exe workflow : You should now be able to drag'n'drop the dll directly in Windows Assembly folder :

Code:
c\Windows\assembly 



and it should register itself Smiley

Let me know if there are any issues.

KS
Back to top
 
 
IP Logged
 
SpaceMadness
YaBB Newbies
*
Offline


I love HDR

Posts: 2
Re: sIBL_GUI For XSI
Reply #190 - 10/03/10 at 23:28:03
 
Hey I've installed the latest server and the XSI GUI, along with the third version of SIBL ... i get this screen after "LaoderScript Sibl XSI import .js Output is done ...
...
any idea waht that could be ?

i use Softimage 2011 built 9.0.242.0 64 bit

thanks
Back to top
« Last Edit: 10/04/10 at 02:27:26 by SpaceMadness »  
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #191 - 10/04/10 at 13:04:56
 
Hi SpaceMadness,

Do you see the server properties in SI ( Model -> Get -> Primitive -> Lights -> sIBL_GUI_XSI_Server Properties ) ?

If it's not the case Did u registered the server with gacutil.exe ?

KS
Back to top
 
 
IP Logged
 
SpaceMadness
YaBB Newbies
*
Offline


I love HDR

Posts: 2
Re: sIBL_GUI For XSI
Reply #192 - 10/05/10 at 03:37:04
 
Oh geez,, thanks it like a charm now !
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #193 - 10/05/10 at 09:24:38
 
Roger Smiley Have fun !

KS
Back to top
 
 
IP Logged
 
Pinin
Senior Member
****
Offline


Curious Apprentice

Posts: 91
Re: sIBL_GUI For XSI
Reply #194 - 10/15/10 at 09:19:15
 
Bug?
I have an issue, i am using the Charleston Sunset from HDR-VFX promo library, and or is there a bug in program or that SIBL is wrong. The SIBL-ground in it needs to be adjusted ie:rotated to fit to horizon line. Would not be a big issue if was just a normal scene but since i am making a simulation i need that SIBL-ground horizontal and when i move the whole scene after unlocking all locks obviously the viewport vs  rendering image shifts.

I am using a 1100 feedback radius. That was the measure i have found that i have the viewport feedback/rendering fit.

Also i am in XSI 2011
Back to top
 
 
IP Logged
 
Pages: 1 ... 11 12 13 14 15 ... 21
Send Topic Print