Welcome, Guest. Please Login or Register
Home Help Search Login Register
Pages: 1 2 3 4 ... 21
Send Topic Print
sIBL_GUI For XSI (Read 68513 times)
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #15 - 09/21/08 at 18:31:38
 
Quote:
I am going to say it once again.... YOU AREEEEE THE MAAAAAAAAN !!! with the singing voice ehehhe

Thanks to all HDRILABS team too Smiley Cheesy Cheesy Cheesy Cheesy


Yarrrrrr ! :]]]
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #16 - 09/21/08 at 18:36:46
 
just one question when i try to send to sofware using remote connection it says Loader script output done! when pressing OK then I get
Remote connection Failed on Port : 12288
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #17 - 09/21/08 at 18:41:02
 
Quote:
just one question when i try to send to sofware using remote connection it says Loader script output done! when pressing OK then I get
Remote connection Failed on Port : 12288


It's certainly because the sIBL_GUI_XSI_Server is not started. The first time you install the server Addon you have to manually start the server (it will be automatically started next times you launch XSI). It's located near the others sIBL_GUI menu entries. Let me know if you have any problems, the new server addon should work on 32 and 64 bits XSI.
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #18 - 09/21/08 at 18:44:44
 
Hmm strange the server is not appearing in the list? I uninstalled it try again still no server in the list
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #19 - 09/21/08 at 18:47:40
 
sorry man my bad i see there are 2 files to be installed Smiley
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #20 - 09/21/08 at 18:48:52
 
Quote:
sorry man my bad i see there are 2 files to be installed Smiley


Hehe yeah no problem I'll try to make it more clear. It's currently not really  Grin
Tell me it works !!!! ^^ Cheesy
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #21 - 09/30/08 at 23:15:31
 
Hey o/

I updated sIBL_GUI today, a lot of changes on both sIBL_GUI and the XSI Template. I also did a screencast with the 0.9.5 version :

sIBL_GUI For XSI Screencast (55,4 Mo)
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #22 - 10/09/08 at 11:59:44
 
Thank you for the great update Smiley  works like a charm
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #23 - 10/09/08 at 13:51:32
 
how hard would it be to add a feature to turn the background primary ray visibility in the GUI options ?
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #24 - 10/09/08 at 21:01:03
 
Hello Keksonja o/

You would like to have the possibility to directly have your background not displayed in the render ? In fact if you dont check create background in the common attributes, there should not be anything connected into the eye rays slot of the rayswitch, tell me if it works for you ! (btw I just realised that you will not have any texture on the feedback doing like this, I'll correct this in the next realease)
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #25 - 10/11/08 at 08:31:29
 
Well there is another issue... if you turn off the background by using Create Background False not only that it doesn't create the feedback but  most importantly it does not contribute the light to the scene.  It disconnects the whole Visible Rays (EYE) hookup....

What I would like to have is the ability to just turn the sIBL_Background_Clip - Intensity - Background from 1 to 0

Leaving everything in the viewport visible but on render time not

Also I see that the sun in most cases is too bright does that have to do with the plug the way it translates the intensity or its just the hdr that needs to be fixed ?

Thanks Smiley

P.S. I noticed another thing is that if I turn the feedback to false or off then the lighting contribution changes too.  Is this due to rotation changes that is happening or something else?  (After some testing I confirm that this has to do with rotation constraint or rotation in y of the sphere when its on and off .... not a big issue)
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #26 - 10/11/08 at 10:35:13
 
Hey keksonja o/

I just noticed there is a bug yeah when you turn off Create Background, in fact the rayswitch should always use the fg port to provide the lighting and it's currently not the case ( something that I destroyed when I improved the template). I will correct this, it's just a line of code.
The Background texture now stay visible in the viewport. It's more user friendly this way Smiley.
The excessive sun brigthness is certainly caused by the physical sun shader option, I need to average it with the classic sun (at leas find about the same intensity output).
I know for the rotation thing, it's an old thing I need to correct !

I will release an improved template really soon (1 hour max) that should correct all this (except maybe the feedback rotation).

See you soon and thank you very much for testing ! Smiley

Thomas

Edit : Oh and for the sun brightness thing, since it's rendered in linear workflow you should compensate your input colors :

a 0.5 grey should turn into a 0.5*(1/2.2) = 0.22725 one (that may explain why you find the sun really bright)

And for the rotation thing, in fact the script is crashing when you desactivate the feedback creation :| It should be fixed in the new template.
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #27 - 10/11/08 at 10:54:52
 
Here is the improved/corrected template :

http://kelsolaar.hdrlabs.com/sIBL_Framework/XSI/Templates/Nightly/XSI_MentalRay....

Thanks again mate to provide feedback, it's only this way we can improve the stuff :]

Thomas
Back to top
 
 
IP Logged
 
keksonja
Ex Member


Re: sIBL_GUI For XSI
Reply #28 - 10/13/08 at 15:05:44
 
From quick testing it works fine... well the script never crashed for me even with that create feedback option... i just noticed that the rotation changes but that is not a big deal like you said its always nice to have feedback and I agree.

As I work with the plug if I notice something else I will let you know.

Thanks for your great work ! Grin

Also the sun option maybe comes form the multiplier but its not a big deal i just take it down manually its fine
Back to top
 
 
IP Logged
 
Kel Solaar
Moderator
*****
Offline


Curious Apprentice

Posts: 1117
Re: sIBL_GUI For XSI
Reply #29 - 10/13/08 at 16:08:03
 
Hi :]

The feedback should not rotate anymore I think ( I didnt double checked but it seems to me that after correcting the bugs, the behavior was correct). I will certainly add a new option where the template will try to update the scene more than a full clean/deletion each time. For your sun intensity you can maybe calm it down in the sIBL file directly so you don't have the problem each time (you have a shortcut directly to sIBLedit in sIBL_GUI).

Thanks for your feedback !
Back to top
 
 
IP Logged
 
Pages: 1 2 3 4 ... 21
Send Topic Print