Welcome, Guest. Please Login or Register
Home Help Search Login Register
Pages: 1 2 
Send Topic Print
Can't get sIBL for Maya to work? (Read 10465 times)
wesm
Ex Member


Can't get sIBL for Maya to work?
08/13/07 at 04:26:13
 
Hi,

I have sourced the mel script and saved it to a shelf, but when I then click on the button, nothing happens. I have successfully used sIBL for LightWave and it's awesome! I'm not sure what I'm doing wrong with the Maya verison. Can someone please help?

thanks!

Wes
Back to top
 
 
IP Logged
 
volXen
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #1 - 08/20/07 at 17:13:20
 
Because I got a coding background I personally prefer starting my scripts with the script name so you donīt have to source them. Just create a button for the command sIBL; or enter this command at the command line ...

Hope this helps!

Greetings,
v
Back to top
 
 
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #2 - 08/21/07 at 00:07:57
 
Hi,

I got the script to load - thanks for the help. I'm sorry to say that I'm having another issue. Upon loading the script is asking me to change the path to the sIBL library. I've already loaded this for LightWave and have the sIBL library called sIBL-Collections. I get an error when I try and change the path to this. It says something about invalid type -Collections. I tried to rename the library, but I still keep getting the same error. I'm sorry I'm not at work now so I can't give you the exact error.

I opened the mel script and it looks like its looking for a path on the H drive. I also tried changing this in the mel script to my path, but I get the same error of invalid type -Collections. It's like it has something to do with the naming of my sIBL library.

Does the sIBL Library need to be called something specifically?

thanks,

Wes
Back to top
 
 
IP Logged
 
volXen
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #3 - 08/24/07 at 15:51:07
 
Thanks for reporting this bug. Yes, the procedure I passed the folder name to interpreted the "-" as
a flag sing which it isnīt in this case. I added some brackets and now it works for me.
The updated file (V0.141a)  is once again found here:

http://www.renderwahnsinn.de/sIBL.mel

I will keep on working on the script next week so tell me when you come across
another problem Smiley

Greetings,
V
Back to top
 
 
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #4 - 08/24/07 at 21:04:14
 
Thanks for the update!

I'll give it go and I'll let you know if I run into anymore problems.

Thanks!

Wes
Back to top
 
 
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: Can't get sIBL for Maya to work?
Reply #5 - 08/28/07 at 01:25:13
 
Well, it would also be helpful to let us know if you DON'T run into problems anymore. Just as a confirmation....

Blochi
Back to top
 
WWW  
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #6 - 08/28/07 at 01:40:57
 
I'm still getting the same error from above. I replaced the file with the new sIBL.mel script in my scripts folder.  The error I get when I try and point to my sIBL Collection is "Invalid Type -Collection."
Maybe I'm still loading the old sIBL.mel script somehow.

I deleted the sIBL.mel from my script folder, but when I type sIBL from the command line it still runs.
I'm fairly new with Maya, so loading scripts is still a little confusing.

Thanks for your help! I'm very excited about using this plugin with Maya. I've been using the sIBL LightWave version and it rocks!

thanks,

Wes
Back to top
 
 
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: Can't get sIBL for Maya to work?
Reply #7 - 08/28/07 at 02:56:09
 
grrr ... how about renaming that folder to sIBL_Collection or something else? You might have to re-register it with the other plugins, but in the end it doesn't matter what the folder is called....

Blochi
Back to top
 
WWW  
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #8 - 08/28/07 at 04:09:32
 
Yes, I've tried to rename the folder and this broke the lightWave setup and I couldn't get that to work again. I even tried reinstalling the LW plugins. In the end, I had to rename the library back to sIBL-Collections to get the LightWave sIBL to work.
Back to top
 
 
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: Can't get sIBL for Maya to work?
Reply #9 - 08/28/07 at 06:15:34
 
err ... re-download the LW Loader, have just put up a new version. I remember this beeing a bug, but should be fixed now. Just tried it, and it was falling back into the "First-time" setup routine where it is asking you for the sIBL Collection....

Blochi
Back to top
 
WWW  
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #10 - 08/28/07 at 12:42:47
 
thanks blochi!

I'll give this a try today and let you know if I was able to resolve the issue with the Maya Loader by renaming the sIBL-Collection folder.

thanks,

Wes
Back to top
 
 
IP Logged
 
volXen
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #11 - 08/29/07 at 17:47:31
 
I just tested everything in a new environment with Blochiīs latest sIBL-set... and yes, I have to admit there is another sdr -> ibl naming problem. My fault ...  the script http://www.renderwahnsinn.de/sIBL.mel is once again updated, please give it another try.
One more issue that will be fixed in the next version (0.15) is that you need to enter your sIBL-directory
with closing / or \  otherwise youīll get the old error again.

V
Back to top
« Last Edit: 08/30/07 at 01:03:06 by N/A »  
 
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #12 - 09/07/07 at 00:25:51
 
Hi,

I had a chance to test the script again. I followed the above instructions about adding a /or\ to the path.
I now get the following error:

// Error: Invalid flag: -SkyDome

Here is the path to my sIBL collection that I am entering into the script.

M:\3D_Content\Texture_Library\HDRI\sIBL-Collection\

I am currently using version 0.141 Alpha

I see in the forums that there is a new version 0.15. I haven't tried this yet and will give it a try as soon as I can.

thanks!

Wes

Back to top
 
 
IP Logged
 
volXen
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #13 - 09/07/07 at 00:58:34
 
Yeah, grab the new version from http://www.renderwahnsinn.de/sIBL.zip.

I canīt wait to get feedback Smiley

v
Back to top
 
 
IP Logged
 
wesm
Ex Member


Re: Can't get sIBL for Maya to work?
Reply #14 - 09/11/07 at 16:53:26
 
Hi volXen,

I tried the new 0.15a version and it works!!!! Grin
Fantastic Job on this plugin! It's awesome.

I like the sIBL_setup script for adding a shelf. This worked just fine.

I was getting an error of "invalid flag -skydome". I looked at a few images that I added to my sIBL Collection and found that some of the names in these files were named like "building-skydome.hdr". This is were I was getting the error. It was having "-" in the name of the hdr file that was invoking the "invalid flag -skydome" error. I went into my collection and renamed these files and everything was fine.

I did a test render and everything worked just fine!

Thanks again and I look forward to future releases.  Grin

thanks,

Wes
Back to top
 
 
IP Logged
 
Pages: 1 2 
Send Topic Print