Welcome, Guest. Please Login or Register
Home Help Search Login Register
Page Index Toggle Pages: 1
Send Topic Print
LW plugin issue ? (Read 6705 times)
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
LW plugin issue ?
07/18/07 at 01:27:26
 
Hi !

I think i found first issue/BUG in LightWave version?

Every time when i start s IBL setup plugin to change HDR image (or load new one in empty scene) it resets whole scene and switch back Camera to "Classic" instead Perspective or Advanced or any other choosed in LW default settings. Classic Camera is OLD (slower) camera/raytracer so if it must reset for some reason let it be Perspective (faster raytracer) but best would be to read Lw DEFAULT Camera settings so it's choosing what user choosed inside of LW.

Thanks and cheers
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: LW plugin issue ?
Reply #1 - 07/18/07 at 02:54:02
 
Hi Lewis,

I believe this is caused by the Setup Radiosity option.
Originally, I was coding this before 9 was out - even started in 7.5 times. And the way to setup fast radiosity was to use real motion blur to effectively multisample radiosity.
But you're right, I should take that out.

Blochi
Back to top
 
WWW  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #2 - 07/18/07 at 09:26:54
 
Hi Blochi !

Yes it's problematic sometime so if is possible it would be great to get update/FIX Smiley. Old Radiosity hack/trick with MB is now outdated and not needed in 9.2 as you know. Just enable Interpolation in radiosit if needed and that will do it fast Smiley. If it can read current state of scene that would be great so that when I load scene and start sIBL plugin just fix HDRIs and don't mess up settings from scene (Camera type, radiosity options..).

thanks and let me know what I can test more Smiley.

P.S. I had some error message sin 64-bit version of LW 9.2 while changing Images in sIBL while in 32bit same that worked fine. I'll grab you screen of that message next time. Maybe we need "BUG report" forum Smiley?
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #3 - 07/18/07 at 14:56:56
 
another ONE.

In Lw 9.2 when i CLEAR scene and close LW (or just close without clearing first) LW crashes after closing with "lwtools.dll" error. Not a big deal since obviously I'm closing it anyway but not a pretty sight either Smiley.
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: LW plugin issue ?
Reply #4 - 07/18/07 at 14:59:43
 
Well, this IS the bug report forum.  Wink

Please do post the 64 bit error - I was sure to have them fixed...

So, yeah, the behaviour you want (not touching anything but HDRIs) should be when you disable "Setup Radiosity". However, in this case you should remember yourself to dial down sample settings - because you only need very few samples for this to work.

Blochi

PS: You can upload a screenshot to this forum as well... just attach it to your post

Back to top
 
WWW  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #5 - 07/18/07 at 15:19:24
 
Ok I'll post bugs when i find them wiht screen grabs. I'm testing right now and ofcourse today i can't get that error in 64-bit i was getting yesterday Smiley Smiley. Maybe that's even better Smiley.

P.S. Can i BUG report forum look somewhere Smiley? Forum look like total mess in MSIE 7.0 Sad. Top menue is shifted to left while rest is centered (I'm on 2560*1600 resolution), topics where I post become one thin line of text (liek something is blocking text to show up) and so on Sad. Its little better on FireFox 2.0.X (I'm using it at work) but some icons are stil on top of text menues and similar stuff. I can make screen grab of that if you want ?
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: LW plugin issue ?
Reply #6 - 07/18/07 at 17:02:02
 
Uff.

Yeah, bugs on every corner.
Stiil it be better to post bugs here. Just fixed the line heights so the forum is at least working in IE7 - still not as pretty, though...  For now, Firefox/Safari/Opera are the way to go. Gonna do cosmetic IE7 fixed later.

Blochi
Back to top
 
WWW  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #7 - 07/18/07 at 21:57:18
 
Heheh , sorry for so many bug reports at once Smiley. Thanks for FIX, I'll check how it looks at MSIE 7.0 when I get home.
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #8 - 07/19/07 at 00:08:15
 
Just to dorp you note that MSIE 7.0 justification still don't working but text subjects in forums seems to be fixed.
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: LW plugin issue ?
Reply #9 - 07/19/07 at 02:09:13
 
True, it's not really fixed yet, just barely patched so the functionality is there....  just trying to keep all the balls up in the air right now.   Roll Eyes



Back to top
 
WWW  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #10 - 07/19/07 at 02:21:40
 
No Problem, take your time to fix it properly when time alows but keep in mind that 60+ % of WEB browsers is MSIE 6/7 now days Wink.

P.S. It's also same mess in Netscape 7.2 Browser (even worst, fonts are too BIG and they exceed limits of design graphics so they aren't visible in full lenght - more like cut off at 2-3 last letters).
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: LW plugin issue ?
Reply #11 - 07/19/07 at 03:39:01
 
Actually, not really. My stats say:

59%      Firefox
22%      Internet Explorer
10%      Safari
5%      Opera
2%      Mozilla
<1%      Netscape
<1%      Camino
<1%      Unknown
<1%      Konqueror
<1%      OmniWeb
IE is still a big chunk, but not priority anymore... Now, I did block out IE6, because that was hopeless.

PS: Back to the plugin - couldn't reproduce a bug on 64 bit LW. However, I do have random bug messages pop up in other LScripts, every once in a while. Apparently LScript itself is flaky under 64 bit... but in a random fashion. If you encounter that problem, you should save the scene, and restart LW anyway, because you're walking on the edge of crashing... Had that happen twice today, but with FPrime.

Blochi
Back to top
 
WWW  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #12 - 07/19/07 at 09:10:53
 
Hmm, stats of what ? Visiting this page or general?? I'm talking abut GENERAL WEB stas and there AFAIK IE6 still leads and IE 5+6+7 are around 60% as I thought

check this link for Browser statistics

http://www.w3schools.com/browsers/browsers_stats.asp

Browser Statistics Month by Month
2007      IE7        IE6           IE5      Fx       Moz         S           O
Jun      19.7%      37.3%      1.5%      34.0%      1.4%      1.3%      1.8%
May    19.2%        38.1%        1.5%    33.7%    1.3%     1.4%     1.7%
Apr      19.1%      38.4%      1.7%      32.9%      1.3%      1.5%      1.6%
Mar      18.0%      38.7%      2.0%      31.8%      1.3%      1.6%      1.6%
Feb      16.4%      39.8%      2.5%      31.2%      1.4%      1.7%      1.5%
Jan      13.3%      42.3%      3.0%      31.0%      1.5%      1.7%      1.5%
                                                        
About 64bit error, yes you are right that's occasional error message I was getting Smiley. Now it works so far so no problems there, thanks for all your effort i know it must be crazy now days when you are finishing the book too Smiley.
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Blochi
Administrator
*****
Offline



Posts: 1726
Hollywood
Re: LW plugin issue ?
Reply #13 - 07/26/07 at 05:48:44
 
back to the original bug -

I cannot replicate that here.

Perspective Camera and Advanced Camera are perfectly retained when I run the script.
However, since you do have a point in MB not beeing needed anymore with the new camera types, I took it off.

In version 0.99 the Radiosity Types only set sampling rays and AA according to speed level chosen, with "Lightspeed" and "Autobahn" additionally turning on Noise reduction.

Give v 0.99 a shot
http://www.hdrlabs.com/sibl/downloads/sibl-loader_lightwave.zip

Blochi
Back to top
 
WWW  
IP Logged
 
Lewis
Full Member
***
Offline


User #777

Posts: 32
Croatia
Re: LW plugin issue ?
Reply #14 - 07/26/07 at 07:54:21
 
OK Blochi i'll try 0.99, thanks.
Back to top
 

--&&Lewis&&www.lewis.tomsoft.hr&&Skype - lewis3d&&ICQ - 7128177
WWW 7128177  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print